What are the system requirements for using Myprogress v6?

Updated by Helpdesk Coordinator -

Myprogress is a web-based system that you use through your internet browser and requires a compatible browser, with JavaScript enabled, and an internet connection.


The internet browsers that are currently supported are:

- Internet Explorer - Current and most previous version 
- Firefox (PC and Mac) - Current and most previous version 
- Safari (PC and Mac) - Current and most previous version 
- Chrome (PC and Mac) - Current and most previous version

- All users must have Javascript enabled

- Faculty users (or students who can mark competencies) must have Flash Player

 

iOS:
- Recommended at least iOS 8
- 200MB free storage space
- 2GB RAM/memory
- Wi-Fi or data connection


Android:
- Recommended Android 5+
- 200MB free storage space
- 2GB RAM/memory
- Wi-Fi or data connection
- Dual core processor is normally OK - Quad core provides smoother experience

 

You can download compatible browsers and plugins using these links:

Internet Explorer - microsoft.com

FireFox - mozilla.org

Safari - apple.com

Chrome - google.co.uk

Flash Player - get.adobe.com

Not what you're looking for? Why not ask the community?

Comments

Powered by Zendesk